Outbound Email Delays

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 18:42 GMT

Monitoring

We're processing a backlog of messages and will continue to monitor the situation closely
Posted Mar 08, 2025 - 12:30 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 08, 2025 - 11:33 GMT

Investigating

Some users may be experiencing outbound email delays. External providers like Google Apps or O365 aren’t affected. Our team is investigating.
Posted Mar 08, 2025 - 11:07 GMT
This incident affected: Outgoing Email.