Connecivity Issues

Incident Report for Deskpro

Resolved

This has now been resolved
Posted Jan 15, 2020 - 22:18 GMT

Investigating

We are currently investigating the issue
Posted Jan 15, 2020 - 22:16 GMT