Increased latency
Incident Report for Deskpro
Postmortem

Increased latency to our file storage provider (AWS S3) caused requests to return slower than usual. The engineers deployed a hotfix to route S3 requests through Cloudflare, which has resolved the issue.

Posted Aug 20, 2019 - 10:41 BST

Resolved
The issue should now be resolved.
Posted Aug 20, 2019 - 10:37 BST
Investigating
We are seeing increased latency affecting some customers. We are investigating.
Posted Aug 20, 2019 - 10:19 BST