SSL errors on some custom domains

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Jan 13, 2023 - 13:27 GMT

Identified

We are aware of SSL errors on some cloud accounts using custom domain names.

The issue has been identified and we are working on a fix.
Posted Jan 13, 2023 - 13:12 GMT