Service Issues affecting some UK based customers

Incident Report for Deskpro

Resolved

We are sorry for the disruption here, the issue has been resolved.
Posted Apr 27, 2020 - 12:46 BST

Investigating

We are working to resolve this issue and expect normal service to recover in a matter of minutes.
Posted Apr 27, 2020 - 12:38 BST