Connectivity Issues

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Nov 25, 2021 - 09:02 GMT

Monitoring

We have applied a fix, the platform has returned to normal and we continue to monitor.
Posted Sep 30, 2021 - 11:05 BST

Investigating

We are investigating connectivity issues affecting some customers
Posted Sep 30, 2021 - 11:02 BST