Incoming email backlog in the UK1 region
Incident Report for Deskpro
Resolved
This incident is now resolved and we've seen no problems over the past few hours.
Posted Sep 01, 2022 - 16:52 BST
Monitoring
The backlog is now being processed normally.
Posted Sep 01, 2022 - 13:49 BST
Investigating
We are aware of an email backlog affecting some customers in our UK1 region. We are investigating the cause and will update this post when we have more information.
Posted Sep 01, 2022 - 01:30 BST
This incident affected: Incoming Email.