Delayed email processing

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 23:32 BST

Monitoring

A fix has been implemented and delayed messages will start being reprocessed.
Posted Apr 23, 2026 - 21:12 BST

Investigating

A subset of customers on Deskpro Cloud are experiencing delays for incoming emails. We are currently investigating this issue.
Posted Apr 23, 2026 - 18:40 BST
This incident affected: Incoming Email.