Issues at Cloudflare are causing intermittent connectivity problems

Incident Report for Deskpro

Resolved

Cloudflare report that the issue has been resolved.

Normal service should be fully restored. If you continue to experience any issues, please reach out to [email protected].
Posted Nov 18, 2025 - 15:04 GMT

Update

Cloudflare report that they have identified the problem and that a fix is being implemented.
Posted Nov 18, 2025 - 13:12 GMT

Monitoring

Cloudflare, a service provider used all over the world including by Deskpro, is having global network issues. This is causing intermittent issues accessing Deskpro and performing certain functions (e.g. downloading attachments), as well as APIs required by third-party services (e.g. telephony services, SMS, WhatsApp).

Cloudflare is aware of the problem and service is recovering. You can follow along here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 12:46 GMT
This incident affected: Admin Interface, Agent Interface, User Interface / Portal, Reports Interface, Billing Interface, API, and Incoming Email.