Service disruption for some customers
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted May 31, 2022 - 16:19 BST
Monitoring
All affected accounts are back online.
Posted Mar 28, 2022 - 16:48 BST
Identified
We have identified an issue affecting a small number of users caused by a problem with a specific database cluster. We are moving affected users to a new cluster.
Posted Mar 28, 2022 - 15:04 BST