Service disruption

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 15:50 GMT

Monitoring

Usual service restored & monitoring situation.
Posted Feb 06, 2026 - 15:14 GMT

Update

We are continuing to investigate this issue.
Posted Feb 06, 2026 - 13:55 GMT

Investigating

We are currently investigating an issue affecting access to our service. Some users may experience intermittent availability or slower response times.

Our team is actively working to identify the cause and restore full service as quickly as possible.
Posted Feb 06, 2026 - 13:54 GMT
This incident affected: Admin Interface, Agent Interface, User Interface / Portal, Reports Interface, Billing Interface, API, Incoming Email, and Outgoing Email.