The issue has been fixed, and AI functionality is now working normally.
Posted Aug 20, 2026 - 18:20 BST
Monitoring
The issue has been mitigated and AI features are operating normally.
Posted Aug 20, 2026 - 16:52 BST
Investigating
Some customers on our US hosting region are experiencing errors with Deskpro-managed AI connections, which may prevent AI features from being configured or used. We are investigating.