Degraded Service for Voice and WhatsApp Users

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 00:01 BST

Monitoring

Service from the third-party provider is being restored. Error rates are dropping as systems come back online. The situation is currently stable, and we’re actively monitoring for any changes.
Posted Jul 27, 2025 - 22:08 BST

Identified

Some customers may experience issues with Voice and WhatsApp, and the Billing page may not load correctly. This stems from an ongoing problem with a third-party service we rely on. We've identified the cause and are actively monitoring the situation while also exploring potential workarounds to reduce impact. Updates will follow as we learn more.
Posted Jul 27, 2025 - 18:54 BST
This incident affected: Agent Interface and Billing Interface.