Connectivity Issues

Incident Report for Deskpro

Resolved

The incident has been resolved and service restored. We are very sorry about the disruption caused.
Posted Mar 06, 2020 - 13:35 GMT

Update

We apologise for the delay and disruption this is causing. We are working to resume all services.
Posted Mar 06, 2020 - 13:30 GMT

Investigating

We are currently investigating the issue affecting the service.
Posted Mar 06, 2020 - 13:19 GMT