Service disruption for UK Customers

Incident Report for Deskpro

Resolved

This incident has been resolved. We are very sorry about the disruption caused. We will update with further details shortly.
Posted Mar 01, 2022 - 17:24 GMT

Identified

We apologise for the continued service issues. We have identified the issue with failures in AWS Aurora. We are working to resolve this.
Posted Mar 01, 2022 - 14:19 GMT

Investigating

We are currently investigating a service disruption affecting some UK customers
Posted Mar 01, 2022 - 12:57 GMT