Degraded Outbound Voice Call Functionality

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 18:44 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2025 - 16:05 BST

Investigating

We are aware of an issue causing degraded performance with outbound voice calls, affecting some customers. Our team is currently investigating and working to resolve the problem.
Posted Oct 01, 2025 - 11:00 BST