Delayed Outgoing Email
Incident Report for Deskpro
Resolved
All mail has been processed. Our sincere apologies for the disruption caused by this delayed mail. We are working to put further safeguards in place to prevent this happening again.
Posted Jun 29, 2020 - 20:56 BST
Identified
All new mail is being processed normally, and we are resolving the backlog which will be processed shortly.
Posted Jun 29, 2020 - 20:12 BST
Investigating
We are investigating delayed outgoing email.
Posted Jun 29, 2020 - 19:52 BST
This incident affected: Outgoing Email.