Cloud Inbound Email Delays
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 15:50 GMT
Monitoring
Incoming email is now flowing as usual but some customers may still see some delays while we finish processing the backlog. We're monitoring closely.
Posted Jan 16, 2025 - 13:50 GMT
Investigating
We are aware of some cloud customers experiencing delays in receiving emails in the EU region, and our team is investigating.
Posted Jan 16, 2025 - 12:31 GMT
This incident affected: Incoming Email.