Images and attachments not loading (EU region)

Incident Report for Deskpro

Resolved

This issue has been resolved. The cause was an internal change to how our systems renew their access credentials, which left file storage temporarily unreachable. Access was restored automatically at 07:00 UTC and the change has been corrected. Only the EU region was affected. We are sorry for the disruption.
Posted Aug 19, 2026 - 11:36 BST

Monitoring

Images and attachments are loading normally again across the EU region, and we have had no new reports since 07:00 UTC. If you are still seeing missing images, please refresh your browser first, and contact us at support.deskpro.com if the problem persists.

We have not yet established what caused this and are continuing to investigate. We will update this page with our findings.
Posted Aug 19, 2026 - 09:46 BST

Investigating

We are investigating reports that images and attachments are not loading for some helpdesks in our EU region. Affected agents see missing images on existing tickets, and some replies containing images fail with an error.

Tickets, replies and all other functions are otherwise working. Text-only replies send normally.
Posted Aug 19, 2026 - 08:42 BST
This incident affected: Agent Interface.