Potential authentication issues with Google Auth on cloud sites

Incident Report for Deskpro

Monitoring

A temporary fix has been implemented for those who have been affected. We are currently working on a longer term fix.
Posted Jul 24, 2026 - 12:46 BST

Identified

The issue has been identified an we are working on a fix.
Posted Jul 24, 2026 - 11:26 BST

Investigating

We are currently investigating reports of authentication issues using Google SSO. Other methods of authentication seem to be unaffected.
Posted Jul 24, 2026 - 10:27 BST
This incident affects: Agent Interface.