Cloud Outbound Email Delays
Incident Report for Deskpro
Resolved
The issue at Sendgrid has been fully resolved.
Posted Nov 22, 2024 - 08:54 GMT
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2024 - 20:32 GMT
Monitoring
We've implemented a workaround to the issue at Sendgrid and outbound email has resumed flowing.
Posted Nov 21, 2024 - 20:31 GMT
Identified
There is an issue with our email partner, Sendgrid. We are working with Sendgrid to resolve the problem.

Customers using their own email accounts (e.g. Google, Office365, etc) are not affected by this.
Posted Nov 21, 2024 - 19:46 GMT
Investigating
We are aware of some cloud customers experiencing delays in sending outbound emails, and our team is investigating.
Posted Nov 21, 2024 - 18:27 GMT
This incident affected: Outgoing Email.