We are investigating connectivity issues with Deskpro

Incident Report for Deskpro

Resolved

A database failover caused approximately 3 minutes of downtime. We apologies for the disruption and are invesitgating the root cause.
Posted Jun 06, 2023 - 14:40 BST

Investigating

We are currently investigating this issue.
Posted Jun 06, 2023 - 14:36 BST