Network Connectivity

Incident Report for Deskpro

Resolved

We apologies for the disruption here, the issue is now resolved.
Posted Sep 19, 2019 - 14:14 BST

Investigating

We are currently investigating this issue
Posted Sep 19, 2019 - 14:11 BST