Mail Processing Delays

Incident Report for Deskpro

Resolved

This issue has been resolved.
Posted Apr 24, 2020 - 11:34 BST

Investigating

There has been a delay in some mail processing occurring from approximately 8.00am GMT. The root cause has been issued and we are catching up all delayed mail. Our apologies for this disruption.
Posted Apr 24, 2020 - 09:32 BST
This incident affected: Incoming Email.