Degraded Service

Incident Report for Deskpro

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 11:10 GMT

Update

Normal service has now been restored, and we are continuing to monitor.
Posted Dec 10, 2025 - 08:50 GMT

Monitoring

We’ve identified an issue affecting service availability and are actively implementing a fix. Normal operation is expected to return soon, and we will provide updates as recovery progresses.
Posted Dec 10, 2025 - 08:39 GMT