Cloudflare Outage
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 11:06 BST
Monitoring
Cloudflare, a major service provider, experienced a widespread outage this morning resulting in Deskpro failing to load.

The issue appears to be resolved and we are monitoring the situation.

Read more from Cloudflare here:
https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 08:19 BST