We are investigating connectivity issues affecting some customers
Incident Report for Deskpro
Postmortem

A core piece of infrastructure on our Cloud platform, the database, is being updated. Our team has been performing many tests on the new version over the last few weeks, all of which have been successful.

Yesterday, at 09:00 BST, our team deployed a new read-only slave to a small subset of customers. This new slave began to fail at around 13:40 BST, causing a number of HTTP endpoints to fail. Our team removed the failing slave from the cluster at 14:01 BST to restore normal service. We are still investigating the nature of the failure on the slave to ensure it cannot happen again in the same way.

Posted Sep 11, 2024 - 09:40 BST

Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 14:18 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2024 - 14:04 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 10, 2024 - 13:59 BST
Identified
We are aware of some customers in the US1 region are experiencing issues using the agent interface.
Posted Sep 10, 2024 - 13:45 BST
This incident affected: Admin Interface and Agent Interface.